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ISHMAEL:
Integrated S ystem for H olistic M ulti-channel A coustic E xploration and L ocalization
1. Introduction
1.1 What is Ishmael?
Ishmael is a program for acoustic analysis. It contains a spectrogram viewer, three acoustic
localization methods, four methods for automatic call detection, real-time sound recording, a
beamformer, and a log file annotation feature. It is more or less a collection of methods that have
been found useful for analyzing acoustic data sets.
Ishmael’s capabilities are primarily aimed at processing large amounts of sound data quickly and
relatively easily. The sound can be a collection of sound files, or a signal arriving in real time from one
or more microphone(s) or hydrophone(s). It is primarily suited for detecting sounds in large database s
and for locating the source of a sound either in real time or from archived data.
The most basic operation in Ishmael is viewing a spectrogram. The spectrogram is a method for
displaying sounds for visual inspection and analysis. A spectrogram shows time on one axis (in
Ishmael, the horizontal axis) and frequency on the other axis. If you’ve never used spectrograms
before and wish to learn more about them, I recommend Prin cip les o f A n ima l Co mmu n ica tio n (Bradbury
and Vehrencamp, 1998). Another way to learn is to experiment with Ishmael, preferably with
someone more knowledgeable nearby to answer occasional questions.
Ishmael runs in Windows. It has been tested, so far, in Windows 2007 and 2010. The hardware
must be a 486 or Pentium type processor. The amount of memory needed depends on the opera ting
system; use at least 32 Mbytes for Windows 95 and 98, and 64 MBytes for Windows 2000 and NT. The
screen size should be at least 800× 600 so that all of the dialog boxes fit.

1.2 What Ishmael Isn’t
Ishmael is no t particularly well-suited to sound exploration—taking an unknown sound and examining
it in detail to find out and measure its characteristics. For that, I recommend Osprey (cross-platform
[in Matlab]; available in MobySoft http://www.mobysound.org/software.html), or Raven (The Cornell
Lab of Ornithology).

1.3 Companion tutorial
In addition to this manual, we have developed a tutorial that explains the basics of Ishmael and
includes exercises to further your understanding of some of the features of this software. You can
access this tutorial and the associated practice files here: http://www.bioacoustics.us/ishmael.html

2. Obtaining and Installing Ishmael
Go to the web site:
http://www.bioacoustics.us/ishmael.html
Click on the link under the Downloads section to get the latest version of the Ishmael installer.

After downloading it, unzip it, then double-click on Setup.exe. Ishmael will be installed in C: \ Program
Files\ Ishmael\ Ishmael2.5 unless you specify some other place. The installer also makes a link so
Ishmael will appear on the Windows’s Start button, under Programs. If you like, you can place a
shortcut for Ishmael on the desktop: find C: \ Program Files\ Ishmael\ Ishmael X.XX\ bin\ Ishmael.exe,
right-click on it with the mouse, and choose Create Shortcut. Then move the shortcut onto your
desktop.

3. Getting Started
3.1 Opening and viewing a sound file
Ishmael can read and write several common file formats: WAVE (.wav), AIFF (.aif), Sun Audio (.au),
and files containing plain integer or floating point numbers. At this time Ishmael will not open an Mp3
file.
To open a file, choose File → Open file from the menu. Choose your file and click Open. The open a
sound file menu will appear.

3.1.1 The basics tab
On the “basics” tab you’ll see the name of the file you’ve just chosen, the duration of the sound in
seconds, the sample rate and the number of samples in the file.

Fit this file to the window: You can choose to fit the file to fill the entire Ishmael window in time,
frequency or both. (Note: if you have very long files, like 24 hours each, displaying the entire file in
one Ishmael screen may not be possible). This is also where you can also choose which channels to
view when working with a multi-channel file.
Channels to read: If you have a multi-channel file you can also choose which channels to read.
3.1.2 Time Stamps
Next, click on the Time Stamps tab. This is where you can make sure that Ishmael is interpreting time
in a file correctly. Often time is in the header of a file, but in wav files time information is usually in
the name of the file. This is also a great place to convert your local time to GMT if necessary.

.
3.1.3 Advanced
Finally, click on the “Advanced” tab. The “start time in file” option allows you to start some numb er
of seconds into a file. This is convenient when you have long files and are testing a detector on a
sound that begins well into your file and don’t want to wait for the first half of the data to scroll by.
NOTE: if you use this option, make sure you reset the “start time in file” to zero, or your process
(detector, etc.) will not be run on data occurring before the start time you’ve indicated. This goes for
all files you’ve chosen in a directory!

The “Display rate factor” is useful when you want to slow down the scrolling display of a file. This is
often needed when testing a detector, examining unknown calls, etc.
Click the OK button, then click the green arrow in the upper left-hand corner to display the data file

you’ve loaded.

Note: Any time you change the settings for a file or resize the Ishmael
screen/spectrogram box, you must click the Run button to redisplay the file.

3.2 Display Options
Once you click the Run button (the green right-arrow in the main Ishmael window), you should see
sound data scrolling across the screen. There are various ways to control what you see, which we’ll
describe in the following sections.

Note: If you are analyzing a sound file, the scrolling may finish quickly, in which
case changing the display options listed here will have no immediate effect. After changing one
of the options below, click the Run button again to re-display the sound file.
Also: Some of the options listed below can’t be done while Ishmael is analyzing sound. If
the control (button or menu choice) you want is grayed out, you need to click the Stop
button first—the red square—to activate the control.
3.2.1 Signal waveform and spectrogram
Ishmael currently has two ways to display sounds, the signal waveform (or time series) and the
spectrogram. You may display both at once if you like. To turn these on or off, use the View→Signal
waveform and View→Spectrogram menu choices, respectively. Hit the Run button once you’ve made
these choices.

3.2.2 Brightness and contrast
If what you see is all black or all white, it’s probably because the brightness and/or contrast are
adjusted badly. You can fix these by changing the scroll bars in the upper right corner of the window.
The top scroll bar is brightness; slide it along (to the right increases the brightness) until you start to see
something interesting in the main display. Note: after each adjustment, you must click Run to see the
change. You can similarly change the contrast. Typically, you want to set brightness and contrast so
that some background noise is just barely visible, and any animal sounds show up strongly against the
background noise.
NOTE: The scrollbar does not appear if the file you have loaded is very short (<XXX s) and therefore
the window is small. It also does not appear when acquiring real -time sound.

3.2.3

Time and frequency display

You can adjust the time
Ishmael display:

and frequency

displays by adjusting these buttons on the

3.2.4 Time and frequency scaling
The sound you are analyzing may zip across the screen too fast to see, or conversely may crawl along
too slowly to see much detail. To fix these, choose View→ Time scaling from the menu. Type in a new
numeric value for the time scaling and click OK. Click the Run button to restart processing.

Similarly, Ishmael may be showing the wrong frequency band of the sound you’re interested in. One
symptom of this is having your spectrogram occupy only a small part of the display band, with a black
region either above or below the data. On the menu, choose View→Frequency range... and enter an
appropriate value. The frequencies available range from 0 to one -half of the sampling rate, so if your
sound input (in a sound file, or from real-time input) is set at, say, 22 kHz, then the display will show
data between 0 and 11 kHz.

3.2.5 Spectrogram parameters
The spectrogram analysis parameters determine the time and frequency resolution of the
spectrogram. These control how much detail you can see in your sound in both time and frequency.
These resolutions are inversely related, so that choosing finer time detail will give you coarser
frequency detail, and vice versa.
To set the analysis parameters for your spectrogram, choose Compute→Spectrogram parameters
from the menu. If you’re not sure where to start, try these values:

Changing these parameters can change the display quite a bit. Here’s an example of the same wav file
displayed with two different frame sizes:

Note: Ishmael computes a spectrogram by taking “Frame size” samples of the
input signal, multiplying by the window (Hamming or whichever), appending “Zero
padding” samples of zeroes, and calculating the Discrete Fourier Transform of the result. It
then takes the bins corresponding to positive frequencies, scales them by the “Intensity
scaling” method, and uses the result to paint one vertical stripe in the spectrogram. Then
it advances by “Hop size” × “Frame size” samples and repeats the process.

Note that the longer frame size (512 samples) gives us better frequency resolution of these humpback
whale calls. Although these parameters are very important for many kinds of analysis, there is not the
space here to describe how to choose appropriate values for these parameters. Experiment with them
with your files and see what you get. The book mentioned above, Principles of Animal
Communication, is a good place to learn more.
For the frame size, start with 256 samples. Click OK, then click the Run button to start the
spectrogram analysis and display. Change the brightness and contrast scrollbars (the ones at upper
right) to make your spectrogram data clear. Experiment with large and smaller values of the frame
size, and see what detail is visible in the resulting spectrogram. Larger frame sizes give you better
frequency resolution, while smaller ones give you better time resolution.

Note: Other spectrogram programs have other ways of describing spectrogram
parameters. These are related to Ishmael’s parameters as follows: “FFT Size” is the sum of
Ishmael’s Frame Size and Zero padding. “Overlap” is the complement of Ishmael’s Hop size,
or [1 – Hop size]. Overlap is sometimes specified in samples, in which case it is [(1 – Hop
size) × Frame size], or in seconds, in which case it is [(1 – Hop size) × Frame size / Sample
rate].

The “Advanced” tab contains options for changing the window type (5 choices), but for now leave it
set at Hann, and leave the Intensity scaling set at logarithmic. The third option, “If the sample rate
changes, keep the frame size…” should be set to “the same duration in seconds”. Click “OK”, then the
“Run” button (green arrow).

3.2.6 Equalization
Equalization can be very useful for viewing animal sounds. Equalization, a form of automatic gain
control, averages out the absolute level of a spectrogram, so that the background noise level stays
roughly constant over time. It operates on each frequency band—each horizontal stripe—in a spectrogram. For this reason, it helps eliminate continuous narrow-band sounds, such as electrical hum, motors,
and so on. It also helps whiten a spectrogram, making all frequencies equally intense over the long run.

Choose Compute→Equalize ’gram to enable equalization. Equalization has a time constant associated
with it that controls the amount of time it takes for the equal ized spectrogram to reach the
background level. If this time constant is too short, equalization will “equalize away” the animal calls
you are interested in. That is, equalization may happen so fast that after the call starts, the equalizer
reduces the spectrogram level in the frequency band of the call, making the later part of the call fade
into the background spectrogram level. If the equalization time constant is too long, then it takes the

equalizer too long to start up—to take effect after you click the Run button—and to recover from loud
sounds. A good place to start is to make the equalization time constant 2–3 times as long as your call
type of interest. Click the Run button, see the resulting spectrogram, and adjust the time constant
longer or shorter as appropriate.
Here’s an example of a file of harbor seal calls with an annoying, continuous sound at about 60 Hz,
and another at about 180 Hz…….

These harbor seal calls are ~5 s long; in this case a 15 s equalization time constant works well…..

After turning on equalization, you’ll need to re-adjust the brightness and contrast using the scrollbars
at the upper right, and click the green Run button:

4. Loading and Saving Settings
Ishmael can save the values you have specified for various settings—the name of the sound file to anal yze,
the real-time input card parameters, the spectrogram calculation parameters, and so on. To save the se
settings, just choose File→Save settings as from the menu.

4.1 The Ishmael Preferences File (*.ipf)
The file you save the settings in is called a settings file, and has the extension *.ipf. In the dialog box
you can either save all your preferences, including detection parameters, your logfile configuration
and the location of your files on your computer, or just the detection parameters. Give your IPF file a
name that reflects the Ishmael choices you are saving and has the extension “.ipf“ (for example “my
whale detector.ipf”). Here is an example where we have chosen to save all preferences ……

Later, you can choose File→Load settings to retrieve the values you saved. Ishmael also loads a
certain settings file when it starts up every time. This file is C:\ Program Files\ Ishmael \ Ishmael
1.0\ IshDefault.ipf (or the same filename in whatever directory you installed Ishmael in). You can save
your current Ishmael settings in this file by choosing File→Save settings as default. Then the next
time you start Ishmael, these settings will be loaded and used.

Settings files are plain text files. You can copy them, store them in the same directory as your sound
files, and generally treat them as you would any other file. You can also edit them in a word processor
if you like; be sure to save a settings file as plain text, not in the format of your word proce ssor. The
names of most parameters in the settings file correspond fairly well to the names that are in Ishmael’s
various dialog boxes. One very useful thing you can do is to make a settings file that has only a few
chosen parameters, like the time scaling you like, or the automatic detection parameters you need.
When you load a settings file like this, only the values you specify are changed; Ishmael keeps its
current values of all the parameters that aren’t explicitly changed by the settings file.

Make sure you pay attention to the notes in the header of the IPF file when manually editing a
preferences file! If you’d like to restart a detector or try it on a different dataset, you can load the
saved IPF by choosing the File→Load settings option and navigating to your saved IPF file. You can
also drag it from the Windows file browser and drop it into Ishmael.

5. Playing Back a Sound
To playback a sound file, hold down the left mouse button and drag the mouse to draw a box around
the sound. A dotted box will appear on the spectrogram and/or the signal waveform, and the speaker

button will become active on the menu button bar. Click on the speaker button, and the sound will be
played.

Then click the speaker button ( ) to play back the sound. To change the playback sound speed click
on the Run → Playback options and choose your desired speed, speaker type, etc.

6. Opening a Multi-Channel File
In a multi-channel file, you have the option of looking at just one or more than one of the channels,
which is available via the View menu.

On the basics tab, you can choose which channels to read into Ishmael. In this example, we have four
channels in this wav file, and Ishmael finds these and automatically chooses all of them. If you want to
clear these four channels, click the None button, then choose one or two channels, click OK, then click
the green Run button. You will need to adjust the brightness and contrast, and you may need to
adjust the time and/or frequency scaling, to see a clear spectrogram.

Note the difference between the channels that Ishmael reads in and the channels that you view. The
channels that are read in are given to all of Ishmael’s analysis tools, like detection, localization, and
recording, even if you don’t happen to be viewing all of them. You can view (in the spectrogram and
signal waveform) some or all of the channels that are read in. Do this via the View menu.
.

7. Opening unknown file formats
Ishmael is also able to open binary files that are not the typical .wav, .aif, or .au formats . For example,
if we open a file format used in our PMEL/OSU hydrophones, Ishmael does not immediately recognize
the DAT extension nor the format of the file.

Ishmael can open this file if you give it information about the sound file. Typically you must get this
information from the person who created the files (or the instrument that recorded the files).

The parameters you need to fill in are:
 Sampling rate is how fast the sound signal was sampled.
 Number of channels can be anything up to 64 channels. For most audio files it’s either 1
(mono) or 2 (stereo), but a lot of marine data files, such as ones from towed arrays, have
more channels.
 Bytes per sample says how large each data sample is. Most commonly this is 2 (16-bit
samples), though Ishmael also supports 1 (8-bit samples), 3 (24-bit samples), and 4 (32-bit
samples). And most audio data files have integer sample values, but a few use floating-point
samples.
 What to ignore at start of file allows Ishmael to ignore a header in your sound file. You need
to know how large, in bytes, the header is.
 What to ignore at end of file allows Ishmael to ignore a trailer. This is somewhat rare to have
in audio data files, but a few formats have it. Again, find the length in bytes.
 Sample value offset is subtracted from each sample as Ishmael reads it in. For most audio files
this will be 0, but some files use only positive numbers and require a subtraction to get a zero mean signal. The file in the example above, 00016945.DAT, uses a sample offset of 215 , or
32768.
 Byte order refers to how samples are encoded. Unfortunately, Windows and much of the Unix
world encode numbers differently, and you need to know which one you have. (The Windows
encoding is also called “little-endian” and the Unix one “big-endian”.) If your data has 1 byte
per sample, you don’t have to worry about byte order.

8. Monitor a real-time sound signal
Sometimes you want to view a real-time sound coming into Ishmael. Connect your sound signal

source (microphone, etc.) to the sound input card you wish to use. In Ishmael, open the sound input
card using File→Sound card, File→National Instruments input, or File→Data Translation input. Set the
sampling rate and any other relevant parameters. Click OK. Repeat the steps in “View a sound file to
see what’s in it” above to enable equal¬ization and disable other Ishmael options. Click the Run
button. Adjust the time and frequency scaling until the sound scrolls across the screen at a reasonable
pace. Do File→Save settings if you so desire.

To pick out calls as they appear on the scrolling display and save them for later analysis, simply select
each call and do File→Save selection as. A faster way to do this is to make an action for each type of
sound you find. Configure the action to save the current selection and unpause Ishmael. Then all you
need do is select a call when it appears—Ishmael will automatically pause as soon as you click on the
spectrogram—and press your action’s hot key.

9. Record a real-time sound signal
Connect your sound signal source to the sound input card you wish to use. In Ishmael, open the sound
input card using File→Sound card, File→National Instruments board, or File→Data Translation board.
Set the sampling rate and any other relevant parameters. Click OK. Re¬peat the steps in “View a
sound file to see what’s in it” above to en¬able equalization if you want it and disable other Ishmael
options. Choose Record→Record sound from the menu and specify the recording parameters you
wish to use. Do File→Save settings if you so desire. Click the Run button to start the recording.

10. Convert sound file formats
10.1 The basics
In order to convert sound files to a new format, you must open these files and “re-record” them with
Ishmael using settings for the desired format. First, disable Ishmael’s more exotic options by looking
through the menus for check-marks—the only ones you want are View→Signal waveform and/or
View→Spectrogram, and possibly View→All channels. Look through Ishmael’s remaining menus to
see if any other options have check marks Compute →Equalize, Compute →Set floor, Compute →Set
ceiling, Compute →Beamforming, Detect→(anything), or Record→Record sound), and if they do,
disable them. You can also load the file Ishmael Factory Settings.ipf to reset your Ishmael settings.

Note: at this time, Ishmael can convert to .wav, .aif, and .au files, which are the
most popular lossless sound file formats on Windows, Mac, and Unix respectively; MP3 format is
not supported. Make sure you use the correct extension for your desired file type!

Open your sound file with File →Open file and check Fit this file to the window in time and in
frequency boxes and click OK.

On the View menu, choose All channels, Signal waveform, and/or Spectrogram if any of these don’t
have check marks. Click the Run button, then adjust the brightness and contrast scrollbars in the
upper right corner of the window until you can see data in the spectrogram. Adjust spectrogram
parameters to clarify the image using Compute →Spectrogram parameters. Adjust View→Amplitude
range until you can see the waveform clearly. Do File →Save settings if you so desire.

Choose Record→ Record sound from the menu. Check “Start recording whenever you click “Run” and
uncheck “Record only when getting real-time input” on this page, since you’re now using input from
a file. Click on the File names tab at the top of the menu, set the maximum length of each file to a
time longer than any of your sound files – say, 1000:00:00 – and un-check Time-align the sound files.

and enable recording. Make sure you check the “Start recording whenever you click Run” and
uncheck “Record only when getting real-time input” on this page, then click on the File names tab
and choose the directory in which you want to store the converted files. Next click on the “Set file
names” button.

Set the maximum length of each file to a time longer than any of your sound files—say, 1000:00:00.
You can also “Time align the sound files” and “Record only when getting real-time input” if you wish,
then click OK. Next, choose File → Saved file names from the main menu. For the file template, enter
%f.exten where exten is the extension of the file type you are converting to. For instance, if you are
converting WAVE files (with extension .wav) files to AIFF files (with extension .aif), enter %f.aif for the
file template. If needed, you can also convert the time of files to/from GMT by entering the offset in

the GMT options box. Click OK. Lastly, open your original file using File → Open file, then click OK and
click the Run button. Your converted sound file should appear in the directory you chose for recorded
sounds.
It’s usually a good idea to test a converted file to make sure things worked correctly and that your
naming convention was interpreted properly.

10.2 Converting many files at once (batch processing)
To convert a number of files en masse, do File → Open file and simply choose the files at once using
the Shift and Control keys when you click with the mouse, or type Ctrl+A to select all of the files in a
directory. Then instead of clicking the Run button, choose Run→ Batch run from the menu. Un-check
the box labeled Pause after each file and start the batch run.

10.3 Using a default IPF for file conversion
XXXXXXXX

10.4 Subsampling your data
You can also sub-sample your data to convert only part of it. To do this, chose Record→Record
sound→Sampling or Record→Sampling plan.

11. Filtering
There are a few issues in signal analysis that can be best handled by filtering: removing noise that
occurs in a certain frequency band, and filtering a signal in preparation for changing its sample rate.
To remove noise that occurs in a certain frequency band, we want to filter out that band, or
alternatively speaking, pass any sound in the remaining frequencies. For example, in the image below,
the interesting sound here occurs below 500 Hz (0.5 kHz), and we can remove the sound above that
frequency – or alternatively, “pass” the sound below that frequency -- using a lowpass filter.

To do this, open the filtering dialog box (Compute →Signal filtering parameters…). In the dialog box
that opens, choose Lowpass Filter, and enter a Filter order of 20 and a Cutoff frequency of 1000 Hz:

The Frequency Response Function is shown on the right. For each frequency on the X -axis (horizontal
axis), the gain of the filter – the amount of amplification or reduction – is shown. For frequencies up
to about 500 Hz (0.5 kHz), this filter has a gain of 0 dB, which means there is no gain or loss of
amplitude. But at frequencies above 500 Hz, the signal will be reduced in amplitude more and more,
as represented by the gain values becoming more and more negative. At a gain of -60 dB, sounds are
pretty much eliminated, and even at -30 or -40 dB, they are very much reduced. Click OK and then
Click Run on the menu bar or the Run button (the green arrow under the menu bar). You can see

that the sound above about 500 Hz is nearly absent. The lowpass filter has allowed the frequencies
below 500 Hz to pass through it nearly unaffected, while frequencies above that are remove d.

11.1 Important Filtering Parameters
What do the various signal filtering parameters mean?
 Channel says what channel you’re applying this filter to, which is applicable only for
multi-channel files. You can have a different filter for each channel. Or by checking the
“Apply to all channels” box, you can use the same filter across all the channels.
 Filter type indicates how you want the filter to work:
1. A bandpass filter allows sound to pass through between two frequencies you specify,
stopping sound below the lower cutoff frequency and above the upper cutoff frequency.
2. A bandstop filter is the reverse: It stops sound within a given frequency range, allowing
sound to pass through below the lower cutoff frequency and above the upper cutoff
frequency.
3. A highpass filter allows sound to pass through above the cutoff frequency, stopping it
below that. This is useful when you have loud low-frequency sound that you want to
eliminate.
4. A lowpass filter, like the one above, allows sound to pass through below the cutoff
frequency, stopping it above that. This is useful for eliminating high-frequency sounds
(which can be annoying to listen to) as well as in preparation for changing the sampling
rate of a sound by decimation.
 Filter order says how many filter coefficients there are, which in turn affects how sharp
the cutoff is – i.e., how quickly sound is stopped below or above the cutoff frequency – as
well as filter response stability.

11.2 Filter response stability
Sometimes when you pick a filter type and specify the filter order and cutoff frequency or
frequencies, the filter’s frequency response goes haywire. Instead of the nice smooth curve you see in
the frequency response above, you get something like this:

This means that the filter design algorithm wasn’t successful in creating a useful filter. To solve this
problem, try different filter order and cutoff frequency values until you get a reasonable filter.
Generally speaking, you get a better response curve (1) using a lower filter order, and (2) moving the
cutoff frequency (or frequencies) away from the minimum and maximum possible frequencies – from
the left and right sides of the response function graph. Play with these parameters until the filter
design algorithm gives you a reasonably smooth graph.

12. Acoustic measurement in Ishmael
Ishmael can be used to make measurements of calls. Hold down the l eft mouse button, drag the
cursor to make a box around the signal of interest, then right click and the measurement log will
appear. Each successive measurement will be added to the log. If the log has gotten closed, you can
re-open it with View→Datalog.

You can change which measurements are made via the View→Datalog entries menus. The basic
measurements – the start and end time of your box, as well as its lower and upper frequencies – are
the first four measurements listed. These are followed by a long list of acoustic measurements of
various sorts.
Note: The parameters beginning with an M, like M1, M2, M3, etc., are part of a set of special noiseresistant measurements. These measurements focus on the loudest parts of calls – the parts that are
likely to be present even when noise levels are relatively high – and thus offer some stability in
varying noise levels. The system is described in detail in the Mellinger and Bradbury 2007 article (see
References at end of this tutorial).

13. Logging Comments
A log file is a plain text file to which Ishmael appends text upon request. Open a log file using the
Actions→Open log file menu item. Pick a file name and click OK.
To add text to the log file, just choose Actions→Log a comment from the menu. Type in your message,
then click OK or press Ctrl+Enter to write the message to the log file. Log file comments are always
appended to an existing file. To clear the log, choose Actions→Clear log file from the menu.
Logging can also happen as a consequence of Actions and by means of automatic detection. See
below for details.

14. Detection
Ishmael currently has XXX basic methods for automatic detection, and many options that affect the
operation of the detection methods. The first thing to do is to choose a method…

14.1 Detection methods
14.1.1 Energy summation
Ishmael has a variety of ways for detecting calls in a sound signal. The simplest of them is the energy
sum detector, which simply measures the amount of sound present in some frequency band of the
spectrogram. In this method, the values in each vertical strip of the spectrogram are summed. The
sequence of sums, one sum per vertical strip, makes up the detection function. Energy summation is a
useful detection method for scanning sounds to find everything of interest, particularly when the
target sounds may be unknown or highly variable. It can also be used as a first step for a more
sophisticated multi-step classification system.
The summation is done between two frequency limits that you set via the Detect>Energy sum menu
item. Actually the result is the average, not just the sum, of the elements along each vertical strip, so
if you change the frequency limits of the operation, the detection function result stays about the
same when only background noise is present. Typically you set the frequency limits of the sum to

include the frequency range of your call type of interest.
A variant of energy summation uses the ratio between the energy in two frequency bands as the
detection function. In this case, the energy averages in each of the two frequency bands that you
specify are computed along each vertical strip. The ratio between these energy averages gives the
detection function.
To set up the energy-sum detector: Do Detect→Energy sum, enable detection, and choose frequency
bounds. The bounds should encompass the frequency range where the clicks occur but not where
interfering sounds are. For this sound, there aren’t a lot of interfering sounds left after equalization, so
use the whole band where the clicks occur: 1500 Hz for the lower limit and 11000 Hz for the upper limit.
Keep “Enable energy ratios” unchecked for now.

14.1.2 Spectrogram correlation
This method works by cross-correlating a spectrogram of Ishmael’s input signal with a synthetic time frequency kernel. It works well when there is some amount of variability in the call type to be
detected; certain parameters in construction of the kernel can be arranged to allow more or less
variability in the calls to be detected. The construction of kernels, and their performance, is beyond
the scope of this guide, but more information is available elsewhere (Mellinger and Clark, 2000).
To use spectrogram correlation, choose Detect→Spectrogram correlation from the menu. Enter the
contour width, which will be applied to all segments of the correlation kernel, and then click the
Define contour tab. Enter the time/frequency endpoints of each segment of the kernel.
14.1.3 Matched filtering
This method works by cross-correlating Ishmael’s input signal with another signal that you specify, called
the kernel. Cross-correlation is the optimum method for detecting a known signal in white Gaussian
noise (Van Trees, 1968). It works best when the signal you wish to detect is quite constant from one
instance to the next and from one animal to the next.
Matched filtering is typically done with either a natural or a synthetic kernel. To use a natural signal,
find the clearest, most typical example you can of the call you wish to search for. This can be done
using Ishmael’s spectrogram display capability or any other method you like. Select the call, making
the selection just long enough to contain the call and nothing more. Choose File → Save selection as
and save the call as a sound file.
More information on constructing synthetic kernels of animal calls is available from numerous
publications (e.g., Dooling et al., 1982; Buck et a l., 2000). If you do it, construct your synthetic kernel
at the same sampling rate as the sound signals you wish to analyze, then save it as a sound file.

14.1.4 Repetitive calls

This is a method for detecting calls that occur with a high degree of regularity. Many animals,
from whales to fish to birds to insects, produce calls at very regular intervals, and this
regularity is a useful feature for detecting such calls. Typically this method operates on the
detection function produced by another detection method – for example, energy summation
– to produce a secondary detection function to which a threshold is then applied.
After running a detector, you can try adding a regular sequence detector. To do this, choose
Detect→Regular sequences, check Enable, and enter min/max repetition periods of your
repeating calls. These limits are meant to cover the range of inter-pulse intervals (IPIs)
possible. In the example below, the pulse trains here have an IPI of about 0.05 s. Set the
window length to the approximate length of a pulse sequence – and leave the window hop
size at 0.1.

Click Run on the menu bar or the Run button (the green arrow under the menu bar). Adjust
the detection function window so you can see much of the resulting detection function –
something like this:

The two clear pulse trains have detection function peaks far above the rest of the detection function,
so it’s now easy to set a threshold that detected but doesn’t de tect the background noises. You can
also turn smoothing on (0.1s) to smooth the detection function.

14.1.5 Whistle and moan detection: tonal sounds
Coming soon………..

14.1.6 Downloading detectors from the Ishmael detector archive
Our laboratory has developed numerous detectors throughout the years, and we now making them
easily available to others via a drop down menu within Ishmael. Select Detect→Load Detector from
Internet…

This opens a new browser window with a Google world map which identifies the locations and species
of available detectors to download; the same detectors are also presented in list form. Detectors can
be downloaded by selecting from the map or from the list. Selecting from either option will result in a

new browser window that shows just the detector of interest, with a link to the performance
evaluation for that detector.

To see the details of the detector, click once on the link “click here for Ishmael config.file (*ipf)”. This
will refresh the browser page to show the full ipf text file, as displayed below:

To download the detector, right click anywhere on this new page and save it as a text file with an ipf
extension. The *.ipf should be in your Downloads folder. From there, you can place it wherever is the
most practical for your purposes (we suggest making a detector folder for all the detectors you
create) . Once you have the *.ipf file on your computer, you have two options. The first is
recommended. Drag and drop it into a running copy of Ishmael. This will keep most settings that you
have already loaded into Ishmael (file name, channel details, etc.) and only add settings associated
with the detector. The second option involves double clicking on the *.ipf file which opens a
completely new version of Ishmael with the detector settings; you will need to add the details of file
directory, spectrogram settings, etc. yourself or you may not have the values you want.

14.2 Condition the spectrogram
The two detection methods that rely on spectrograms, energy summation and spectrogram
correlation, are affected by how Ishmael calculates the spectrogram and also how it conditions the
spectrogram—whether equalization, spectrogram floor, and spectrogram ceiling are enabled.
Equalization is recommended for animal call detection, as it helps eliminate some common types of
noise like motors and 60 Hz electrical noise. See the “Analysis and display options” section above for
information about equalization.
The choices in Compute→Set floor in ’gram and the Compute→Set ceiling in ’gram affect the
spectrogram-based detection methods too. The floor and ceiling enforce minimum and maximum
values on the spectrogram, respectively. This is useful when, as often happens, there are occasional
very low and very high values in the spectrogram that overwhelm the detection methods. Very low
spectrogram values can happen simply from random background noise, very high values from loud
calls or interfering sounds. To limit the impact that these have on automatic detection, enable the
floor and ceiling. When automatic is checked, the floor or ceiling value is calculated from the setting
of brightness and contrast when you start a Run. The floor value is the level at which sound is just
visible in the displayed spectrogram, below which all sounds are displ ayed equally dark. Likewise, the
ceiling value is the maximum displayable value, above which all sounds are displayed equally bright.

14.3 Examine the detection function
Each detection method analyzes the input signal and produces a detection function, which i s a signal
specifying over time the likelihood that the call of interest is present. Run Ishmael with your detection
method enabled. A window will appear showing the detection function. You’ll almost certainly need
to adjust the amplitude in this window using View→Amplitude range— in fact, often the first time
you run your detector, all that appears is a black box, because the amplitude limits in this box are
adjusted badly and the detection function is outside the limits. The scaling of the detection function
varies depending on the type of detection and the various options you choose; it’s not closely related
to any ordinary unit of measure. The only thing that’s really important in it is the height of the
detection function relative to your threshold. The display is labeled “U” to mean arbitrary Units.
If you can’t see anything at all in the detection function window, try using amplitude limits of 0±100
and clicking the Run button again. When you can see your detection function, adjust the amplitude
limits again to zoom in until you can see the detection function varying with time. You should see
peaks in the detection function where your calls of interest occur, and hopefully not in many other
places.
Note: If you ever change the width of the main Ishmael window, the width of the detection function
window does not change, and its time axis no longer lines up with the main window axis. To fix this,
just close the detection function window; the next time you start a Run, the detection function
window will be re-created at the right size.

14.4 Smooth the detection function
The detection function is often very jumpy over time. It’s usually a good idea to even it out using
smoothing, available via the Detect→Detection options menu choice. As a rule of thumb, smoothing
time constants that are roughly as long as your call type of interest seem to work well. But you can
play with this option a bit to see what works best: What you are trying to achieve is a smoothing time
constant that produces peaks in the detection function where your calls of interest occur and evens
out any other peaks due to background noise. Beware that changing the smoothing constant will
change the absolute level of the detection function; what is important is the relative height of peaks
corresponding to calls and peaks corresponding to background noise. You want “call peaks” that are
high relative to “noise peaks.”

14.5 Set a threshold
You need to set a threshold in this detection function; whenever the detection function exceeds the
threshold, a detection event is triggered. Examine the detection function and pick a value on the y axis that is less than the height of the peaks in the detection function but greater than the normal,
background level of this function. In the Detect→Detection options menu choice, on the Threshold
tab, enter the threshold value you have picked.
Actually, the detection function has to be over the threshold for a certain amount of time to trigger a
detection event. Set the time limits, both the minimum time and maximum time over threshold, using
this same Threshold tab.

14.6 Set a neighborhood
Also on the Threshold tab is the Detection neighborhood time. This value prevents detections from
happening too often, and it’s useful for at least two reasons. First, it prevents echoes and other

multiple-arrival effects from triggering multiple detection events. Second, the detection function
often has a bit of jitter to it—fast, fine-scale movement up and down. As the function crosses the
detection threshold, this jitter can trigger a spurious detection. Setting a detection neighborhood can
prevent this. A good rule of thumb is to use a detection neighborhood value that is about half the
time between the end of one call and the start of the next.
The neighborhood specifies the minimum time after the end of one call— after the time the detection
function goes back below the threshold—before another detection event can be triggered. If this
neighborhood time ends while the detection function is already above threshold, a new event is not
triggered.

14.7 Set up regular sequence detection
Ishmael has a method of analyzing the detection function to look for regular sequences. It works well
for very regular sequences; if there is even a bit of irregularity in the timing of calls, it does not work
very well. If your species produces calls at very regular intervals, try this and see whether it improves
detection performance.
Choose Detect→Regular sequences from the menu to enable it. When enabled, Ishmael does the
following calculation repeatedly (Mellinger and Clark, 1997): It takes a portion of the detection
function that is “window length” seconds in duration, calculates the autocorrelation, finds the largest
value occurring between the min and max repetition periods, and outputs that value. Then it moves
forward by “window hop size” seconds and repeats the operation.

14.8 Specify what to do with detection events
In the Edit actions→Call detected box, or equivalently under the Saving calls tab of the
Detect→Detection options menu choice, specify what you want to do when a call is detected. There
are many options here; see the “Actions” section of this guide for details. One of the options is “save
the current selection.” In the context of automatic detection, the “current selection” is the call being
detected. More precisely, it’s the time span from when the detection function went above threshold
to when it went back below, plus any extra time before and after that you specify on the Saving calls
tab.
Also, in the Edit actions→Call detected box, there are options that make no sense in the context of
automatic detection: “continue running (unpause)” and “go to the next file in a batch run.” These
options are meaningless since Ishmael isn’t paused when it detects a call. No promises are made
about what will happen if you enable these options here.

14.9 Specify file names of saved calls
If you have enabled the saving of detected calls, you need to specify their names via the File→Saved
file names menu choice. File names can include the time and date that the call occurs; this really
works only for real-time input, since Ishmael currently can’t extract timestamps from most types of
sound files. Also specify any amount of extra sound to save before and after the call occurs, using the
Saving calls tab of the Detect→Detection options menu item. If you are saving detected calls in sound
files, it is strongly recommended that you do a trial run and look at a few of these saved files to make
sure that enough time gets saved before and after each call. Sometimes the automatic detector’s idea
of when a call starts is different from your idea.

14.10 Specify the log file
If you have enabled any of the log file options in the Edit actions→Call detected box, you need to
open a log file. Do this with the Actions→Open log file menu choice.

14.11 Run it
That’s it! Click the Run button and Ishmael will process your sound(s), extracting and/or logging the
calls it detects.

14.12 Automatic Detection Summary
This is a list of the settings in Ishmael that can affect automatic detection. If you wish to get the same
result out of successive runs of Ishmael, keep these settings the same. It is strongly recommend to
save a settings file that has your automatic detection settings.
1. The input signal.
2. The detection method—energy sum, matched filter, or spectrogram correlation.
3. Everything in the box that appears when you choose Detect→Detection options.
4. Everything in the box that appears when you choose Actions→Edit actions and then double-click on
the Call detected item.
5. The name specified in File→Saved file names box, if you have checked Save the selection in the
Call detected item. Be aware that the computer’s current time, time zone, and daylight-saving time
setting can affect the file name, because the File→Saved file names box allows you to include a
timestamp in your file name. See Windows’s Start button→Settings→Control panels→Date/Time to
change the time settings.
6. The log file settings under Actions→Open log file, if you have checked any of the logging options in
the Call detected action.
7. Beamforming—whether Compute→Beamforming is enabled, and if so, its settings.
8. Sequence detection—whether Detect→Regular sequences is enabled, and if so, what its settings
are.
In addition, if you use a detection method that relies on spectrograms (energy sum or spectrogram
correlation), these other parameters matter:
9. Spectrogram parameters. The one that matters the most is logarithmic vs. quadratic scaling.
Window type matters somewhat too. The other parameters have correction factors, so changing them
should make only minor differences in the detection function.
10. Equalization—whether it’s enabled, and if so, its time constant.
11. Floor/ceiling values, if used.
12. Brightness and contrast of the display, if floor or ceiling values are used and “automatic” is
checked for them. This one is especially easy to miss, since you often change brightness and contrast
using the scrollbars and don’t really think about it affecting automatic detection. But the automatic
floor and ceiling values are calculated from the current brightness and contrast values when you click
the Run button, and they definitely affect automatic detection. To stop the brightness and contrast
scrollbars from affecting automatic detection, check “manual” instead of “automatic.”
Finally, here is the order in which Ishmael’s sound processing happens. Kn owing this order can help in
understanding what is affecting automatic detection:
 Sound input (from a file or one of the real-time sources) Sound recording
 Beamforming











Matched filtering, if enabled
Signal waveform (time series) display
Spectrogram calculation
Spectrogram equalization
Spectrogram floor and ceiling
Spectrogram display
Energy summation or Spectrogram correlation, if either one is enabled Detection function
sequence analysis
Detection function smoothing
Detection event analysis (applying thresholds, neighborhoods, etc.) Detection actions—
logging, saving a file, etc. (see below) Detection function display

14.13 Manual verification of detections
Once Ishmael has detected sounds of interest, you can manually check them to see whether they are
correct or not. This is important, as often a detector will makes some mistakes. The best way to do
this is to set up Ishmael to save each detection in a separate file. On Detect→Detection
options→Saving calls (tab), click the button labeled Edit the action. In the ensuing dialog box, on the
Actions tab, check the box for Save the selection as a new sound file.

Over on the Saving files tab, choose a directory (folder) to deposit the new files in; this can be any
folder of your choosing.

Click Set file names and use the File template of your choosing. The “%S” option indicates that each
sound file will have the number of seconds since the start of the sound file that the detection
occurred. See Section 15 for information about getting time stamps from your input file into
Ishmael.

14.14 Evaluating the performance of detectors via Matlab
“Evaluating a detector’s performance” means seeing whether it found the calls in your sound files,
and also whether it incorrectly detected things that weren’t calls. One way to do this is to make
performance evaluation graphs called Receiver Operating Characteristic (ROC) curves and Detection
Error Tradeoff (DET) curves for your detector. This can be done in MATLAB using the following
methods and code:
First, we have to know the ground truth, that is, what really IS a call. This is normally done manually,
by having a person scroll through some sound file(s) and pick out the calls in them. The left figure
shows a ROC curve, the middle a DET curve, and the right a histogram of signal -to-noise ratios (SNRs).

More coming soon…………

1) About performance curves: A ROC curve is made by varying the detection threshold over a range
of values and counting the fraction of false alarms (incorrect detections) and correct detections
for each threshold. By plotting one point for each threshold and connecting the dots, MATLAB
makes a curve. Good performance is when the ROC curve comes close to the upper left corner.
The DET curve in the middle is made similarly, but the Y-axis has missed calls instead of correct
detections, the distribution takes the probabilities of the detecting and missing calls into account,
and the curve is shown using log-log scaling so the detail comes out better. Good performance is
when the DET curve comes close to the lower-left corner.
The right panel shows the signal-to-noise ratio for this set of recordings. The SNR says how much a
call stands out above background noise; it’s important for assessing ROC and DET curves because
clearer (higher-SNR) calls are easier to detect. For baleen whale sounds, a SNR of 10 is okay, 15 is
good, and 20 is very good. Most of the data here are in the okay-to-good range, so this is a
reasonable representation of this detector’s performance. If the SNRs had mostly been up around
15-20, we wouldn’t be learning much about this detector because the detection problem
presented to it – detecting some really clear calls – would have been too easy.
A more detailed write-up about performance assessment is in the Signal Processing chapter in
your articles folder.

14.15 Grouping detections
Sometimes it makes sense to group detections together. For instance, when an animal produces
pulse-train vocalizations, like the cusk eel examples above or Atlantic minke whales or screech owls, it
makes sense to lump together all the pulses in a train. To do this in Ishmael, do Detect→Detection
options→Saving calls (tab). The numbers here for before start of call and after end of call determine
how Ishmael will lump successive detections together. Also, on the Advanced tab, you should check
the box for Save successive calls together (allow re-triggering). This will make Ishmael try to lump
successive closely-spaced detections together.
Lumping detections together can affect Ishmael’s output in two ways:
 If you’re saving copies of your calls, which you do with Edit the action and then checking the
box labeled save the selection as a new sound file, any sound files that would overlap in time
(because of the extra buffer time you specify for before start of call and after end of call), then
these sound files get lumped together into a single sound file.

There can be more than two detections that get lumped; Ishmael keeps lumping them together as
long as the successive saved files would overlap.

If successive calls would overlap and get lumped as saved sound files, then they are lumped
together in Ishmael’s log file too. This is true even if you’re not saving sound files; if the saved sound
files would have overlapped, the detections are lumped together in the log.

15. Time stamps in Ishmael
Ishmael is able to interpret the time in a file in a couple of ways.
Choose File→Open file, click on the basics tab, choose your basic preferences, then click on the Time
Stamps tab of the Open a sound file drop down menu. This is where you can make sure that Ishmael
is interpreting time in a file correctly.
If you are opening a *.wav, *.au or *.aif file and that file has the date and time encoded in the name
of each file, you can set up a template that Ishmael parses the name correctly.

For example….
mysound-4-14-99-1052.wav

would be

mysound-%M-%D-%Y-%2h%2m.wav

Optionally, you can choose the second option, Is this date and time and enter this information in the
spaces provided. Finally, a few file formats have time encoded the header of the file (e.g. our
PMEL/OSU hydrophone files) and you denote that with the third option.
Telling Ishmael how to interpret time is very important in many instances. For example, when running
a detector, the time of the detection is written to the log file. If you don’t provide a means for Ishmael
to interpret date and time, you’ll get a log that looks like the one below:

This is also a great place to convert local time to GMT if necessary. If your files were stamped with
local time, and you’d like to convert them to GMT, enter the offset hours in the space provided.
Finally, click on the “Advanced” tab. The “start time in file” option allows you to start some number
of seconds into a file. This is convenient when you have long files and are testing a detector on a
sound that begins well into your file and don’t want to wait for the first half of the data to scroll by.
NOTE: if you use this option, make sure you reset the “start time in file” to zero, or your process
(detector, etc.) will not be run on data occurring before the start time you’ve indicated. This goes for
all files you’ve chosen in a directory!
The “Display rate factor” is useful when you want to slow down the scrolling display of a file. This is
often needed when testing a detector, examining unknown calls, etc.
Click OK when all of your file settings have been made.

16. Advanced detection using the MATLAB interface
Ishmael now has an interface to MATLAB so that detectors written in MATLAB can be run in Ishmael.
If you’re MATLAB-savvy and have a new type of detector you want to try, you can write your detector
in MATLAB and run it from Ishmael. Although there are a few pointers below on how to do this;,if you
are interested in using this feature, contact D. Mellinger.

16.1 Example: Generalized Power Law (GPL) detector
This is an example of using a detector, the Generalized Power Law (GPL) detector, to detect humpback
whale sounds. GPL was developed and written by Tyler Helble; this detector uses his code.


Open a files containing potential humpback whale sounds, make a spectrogram, and make
sure you use the no zero-padding option for this detector. Adjust brightness and contrast
too, and stretch the screen horizontally and vertically until you can see some of the
humpback song units. You can use equalization if you like, though it’s not really necessary,
but do not use a spectrogram floor value since it will cause MATLAB to crash. (It puts a lot
of zeros in the spectrogram, causing problems.)



Launch MATLAB from the Windows Start button.



Find your ‘stubb\plugins\GPL’ directory. It might be in one of these places:
C:\Program Files (x86)\Ishmael\Ishmael 3.0\stubb\plugins\GPL
C:\ C:\Users\<your user name>\AppData\Local\Ishmael\stubb\plugins\GPL
C:\Ishmael\Ishmael 3.0\stubb\plugins\GPL



In MATLAB’s command window, execute this code (you can copy and paste):
cd('<your stubb\plugins\GPL folder>’); % substitute the appropriate folder
addpath('GPL_v2_5')
startup



In Ishmael, do Detect→Use stubb plugin→Algorithm (tab). Check the box for Enable
function from the DCL interface, then click on the Function to Run drop-down and choose
GPL.



Click OK.



Click “Run” on the menu bar or the Run button (the green arrow under the menu bar).
Nothing happens until….



In MATLAB, type in GPLDetector and press Enter. At this point you should see Ishmael start to
run. The detection function is all 1, but in the MATLAB window you will see a list of humpback
detection times. Each one is a pair, the start and stop-time of a humpback song unit. This is
currently the only output from the GPL detector.
Each time you run Ishmael, you’ll need to also run GPLDetector in MATLAB. It doesn’t matter
what order you do them in – each one waits for the other if it’s not running yet.




Sometimes Ishmael and/or MATLAB gets hung up. You have to close both of them, possibly
using the Windows Task Manager: do Ctrl-Alt-Delete and click Start Task Manager. On the
Applications tab, right-click on Ishmael (or MATLAB) and choose End Task.

17. Advanced detection using ROCCA
17.1 What is ROCCA (Real-time Odontocete Call Classification Algorithm)?
ROCCA -- the Real-time Odontocete Call Classification Algorithm – is a system for classifying sounds of
odontocetes (toothed whales, dolphins, and porpoises) to species. It was developed by Dr. Julie
Oswald and implemented by Michael Oswald of Bio-Waves, Inc. Ishmael sends information about
odontocete clicks and whistles to ROCCA, which uses two user-supplied "classifier files" -- one for the
click classifier and one for the whistle classifier -- to make its best estimate of the species that

produced the clicks and whistles. The click and whistle files are geographically specific, in that they are
designed to discriminate among the species that are present in one specific geographic region. ROCCA
can also estimate species for an "encounter" -- a group of clicks and whistles that occur over some
time period such as half an hour -- by combining classification results from all the clicks and whistles
that occur in that time period. You don't have to classify encounters, but if you do, you also need an
"encounter classifier file" to supply to ROCCA.
In more detail, ROCCA operates on both echolocation clicks and, when available, communication
whistles produced by odontocetes. For clicks, Ishmael makes a number of acoustic measurements
based on the spectra of the clicks and sends them to ROCCA. For whistles, Ishmael measures acoustic
characteristics of the whistles such as minimum and maximum frequency, slope, duration, and so on,
and sends them to ROCCA. ROCCA uses tree-based classifiers -- specifically, a method known as
classification and regression trees (CART) -- to make its best estimate of the species producing the
clicks and whistles.
Ishmael has an interface to ROCCA. The ROCCA module uses parameters measured from delphinid
whistles or clicks, along with user-selected random forest classification models, to classify the whistles
and/or clicks to species. Whistles are detected using Ishmael’s Whistle and Moan Detector, and clicks
detected with Ishmael’s Energy Sum Detector.
Individual whistle/click detections and classifications are also grouped together into user-defined
Encounters, a set of whistles and/or clicks that can all be attributed to one school of odontocetes.
Variables describing the acoustic behavior of the encounter are calculated using the outputs from the
whistle and click detectors, and an overall Encounter Classification is generated based on those
variables in combination with the output of the whistle and click classifiers.
For more information on ROCCA and on classifier files for clicks, whistles, and encounters for various
regions, see XXXXXXXXXXXXXXX.

17.2 Implementing ROCCA
ROCCA functionality can be included in the Ishmael application, but requries Java to be installed on
your computer.
About Java
Specifically, in order for Java to be able to allocate enough memory for the large classifier files, the 64bit version of Java must be installed. If you are not sure whether or not you have Java installed, click
on the Windows Start button (lower left corner on the screen) and type ‘cmd’ in the Search Programs
and Files text box. This will open up a white-on-black console window. Type ‘java –version’ at the
prompt and hit enter.
 If you get an error message, Java is not installed. Go to java.com/en/download/manual.jsp
and find the link that specifically says ’64-bit’ (usually it is called Windows Offline 64-bit).
Download and install Java.
 If you do not see the words ’64-bit’ somewhere in the output, you have the 32-bit version
installed. Here’s an example of a 32-bit version:

Don’t worry, you can install both 32-bit and 64-bit on the same machine. Go to
java.com/en/download/manual.jsp and find the link that specifically says ’64-bit’ (usually it is called
Windows Offline 64-bit). Download and install java. This version will now become your default version
of Java. If you need to go back to the 32-bit version (perhaps to run some older programs), the easiest
way is to return to the Java webpage and download/install the 32-bit version (the one that does not
have the words 64-bit in it). Note, however, that Ishmael/ROCCA will likely not be able to load the
classifier files if it is trying to use 32-bit Java.
 If the words ’64-bit’ are included in the output, you have the correct version installed. See the
last line here:

17.3 ROCCA classifier files
You will also need ROCCA classifier file(s) for the region you are interested in. These files contain the
information necessary for ROCCA to evaluate the detections that Ishmael sends to it and classify them
to species. Classifier files for three different regions (Northwest Atlantic, Temperate Pacific and
Hawaiian Islands) can be downloaded from the Downloads section of the Pamguard website
(www.pamguard.org/downloads.php?cat_id=5). Each download is a zipped package containing three
different classifier files (with the prefix .model) and a PDF containing a description of the classifier.
There is a whistle classifier, a click classifier, and an encounter classifier for each region. All three
classifiers are random forest classifiers. The encounter classifier uses the output from the whistle and
click classifiers to identify acoustic encounters (or schools) to species. The description for each
classifier includes information about the species recognized by the classifiers, as well as information
about the datasets used to train them. More detailed information about the classifiers can be found in
Oswald and Yack (2017).
Once you have downloaded the zip file containing the classifiers, right-click on it and select ‘Extract
all’. You are then given the option to specify where to save the files to. Store your classifier files
anywhere on your computer; you can use the Desktop if you like.

17.4 Using ROCCA
1) In Ishmael, open either the click detector using Detect→Energy sum or the whistle detector
using Detect→Whistles and moans. Configure it as described in the Dectection section
(pageError! Bookmark not defined.) so that it detects the desired type sounds of your target
species

2) To enable the corresponding ROCCA classification, check the “Enable Rocca….” box at the
bottom of the window that pops up (“Enable Rocca click classification” for Energy Sum or
“Enable Rocca whistle classification” for tonal sounds). Then click the button labeled Edit
Rocca Parameters.

A new window will pop up to allow you to enter parameters specific to the ROCCA classification
module:
 The Whistle Classifier File and Click Classifier File boxes tell ROCCA which classifiers to use.
Hit the Choose button and select the appropriate classifier file previously downloaded, or type
the path and filename directly into the text box. Either a Whistle Classifier or a Click Classifier
must be specified, but you can specify both if you want. Note that if both are specified, both
will be loaded into memory. For memory-limited machines, this may cause out-of-memory
errors.
 Encounter Classifier File is optional, and will only run if both a Whistle and a Click Classifier
have been selected and the ancillary variables check boxes have been checked. If an
Encounter Classifier is chosen, the encounter (school) will be classified based on the output of
the whistle and click classifiers and the ancillary variables. If an Encounter Classifier is not
specified, encounters will be classified as the species receiving the highest cumulative number
of random forest tree votes in each Encounter.
 The Detection Output File box tells ROCCA where to save information about each whistle or
click detection passed to it by Ishmael. This should be a .csv file. Information for each
detection is added as a new row. See Tables 1 and 2 for the variables that are measured for
each whistle or click detection and saved to the file. The species classification for each
detection is also saved, at the end of the row after all measured variables.
 The Encounter Output File box tells ROCCA where to save information about each Encounter .
This information is saved as a .csv file. Table 3 gives the ancillary variables measured using the
whistles and clicks in each encounter. These variables, along with the random forest votes for
each species and the overall Encounter Classification, are all saved to the Encounter Output
File.
 Encounter Name is a label that lets the user name the current acoustic encounter to group
whistle and click detections under. Changing the name tells ROCCA to begin a new Encounter
and to clear the whistle and click information calculated for the previous Encounter. Each row










of data in the Encounter Output File is a separate Encounter, and includes the Encounter
Name.
Enable Ancillary Whistle Stats gives the user the option of calculating ancillary variables for
the whistle detections in the Encounter (see Table 3). The calculations take time, and if there
are many whistles in the Encounter the calculations may slow down the overall processing. If
you want to use an Encounter Classifier file, ancillary whistle stats must be run. If you are not
using an Encounter Classifier file, the ancillary whistle stats are optional.
Enable Ancillary Click Stats gives the user the option of calculating ancillary variables for the
click detections in the Encounter (see Table 3). The calculations take time, and if there are
many clicks in the Encounter the calculations may slow down the overall processing. If you
want to use an Encounter Classifier file, ancillary click stats must be run. If you are not using
an Encounter Classifier file, the ancillary click stats are optional.
Enable GPS data gives the user the option of sending GPS data to ROCCA. GPS data is used by
the Encounter Classifier to help with the Encounter classification. If Ishmael has not been
configured to accept GPS data, do not check this box.
Whistle and Click Threshold is the threshold value (in percent) to use when classifying
individual whistles or clicks. In the random forest classifier, if the percentage of trees voting
for the predicted species falls below this threshold, the whistle or click is considered non classifiable and is labelled as ambiguous (AMBIG).
Encounter Threshold is the threshold value (in percent) to use when classifying Encounters. If
the percentage of trees voting for the predicted species in the random forest falls below this
threshold, the Encounter is considered non-classifiable and is labelled as ambiguous (AMBIG).

Enter file names either by typing or pasting in the file name, or by clicking the Choose button,
navigating to the folder you want, and entering the classifier file name you want to use.
Once the parameters have been set, you can simply click Ishmael’s green Run button to start the
analysis. The first time you do this, you will see Java launching in a white -on-black command window,
then ROCCA loading the classifier file(s), which typically takes several seconds.

It’s fine to minimize this command window so it’s in your toolbar at the bottom instead of the middle
of the screen.

ROCCA is now running and connected to Ishmael. Whenever Ishmael detects a click or whistle, it will
send it to ROCCA, which will classify each detection to one of its known species (as documented in the
PDF file included in the classifier file download), as AMBIG if the votes fall below the Whistle/Click
Threshold, as NA if the detection has been pruned (see next page), or as ERR if there was an error
during the classification process. Measured parameters and classifications are written to ROCCA’s
Detection Output File. When Ishmael analysis has ended – either by reaching the end of the acoustic
file, or the user manually stopping Ishmael – an Encounter classification is generated and saved to the
Encounter Output File.
Whistle, click and Encounter results can be viewed by opening the .csv output files in Excel or another
spreadsheet program. Note, however, that new results cannot be added to the files by Ishmae l if they
are open in another application, so always remember to close the file before running Ishmael again.
When you close Ishmael, the ROCCA process should stop and the white -on-black command window
should disappear. (If it doesn’t, close it manually by clicking the red “X” in the upper right corner.)

Notes on Pruning: in order to minimize false detections, certain measured whistle and
click variables are tested against predefined ranges to validate the detection. The variables and
ranges are specific to each classifier region, and are listed in Tables 6 and 7. Detecti ons with values
that fall outside of the range are pruned; that is, they are not classified. The detection information
is still saved to the Detection Output File, but NA is given as the classification

18. Localization and Tracking
When set up correctly, Ishmael can do localization—determining the location of a sound source— and
tracking (combining successive locations to estimate movement). Both of these….
 can be done in 1, 2, or 3 dimensions
 are usually done using the differences in the times that a call arrives at several hydrophones
o for example, with two closely-spaced hydrophones, a given time delay corresponds to
a sound source at a certain bearing angle
Having Ishmael set up correctly for all localization methods requires these things:
 Sounds with two or more channels, either from a sound file or from real-time input.
Ishmael’s methods for determining bearings require at least two channels of sound (two
simultaneously operating microphones or hydrophones), and the X-Y position method
requires at least three channels.
 Information about the positions of the microphones or hydrophones.
 Information about the speed of sound.

18.1 General Configuration
To set up Ishmael for doing localization, first create a text file with the positions of your

microphones/hydrophones. This file, the phone array file, should have one line for each phone,
specifying two values per phone: the X- and Y-positions of the phone, in meters, with spaces or tabs
between the two numbers in the file. The positions should be relative to some origin or (0,0) point.
This origin can be anywhere you like, typically at one of the phones or (for towed hydrophone arrays)
at the ship. An example phone array file for a four-phone array looks like this:
-100 20

-20 150

100 30

75 -30

Save your *.arr file, being sure to save it as “text only” in your word processor. In Ishmael, choose
Localize → Loc options... from the menu, choose the Basic info tab, and enter the name of your phone
array *.arr file. Also enter the speed of sound here—in the ocean, it’s typically around 1500 m/s; in
air, typically around 340 m/s. What you do next depends on the type of localizations you want to do.
In the dialog box, pick the appropriate tab:

You need to be sure that Ishmael is getting enough channels of sound— at least two or three
channels, depending on the localization method used. If you are analyzing a file, choose File →Open
file... from the menu; if you have already selected a file, just cancel the file-picker dialog box, and
Ishmael will leave the same file open and let you choose which channels you want to analyze. Select
two, three, or more. If you are analyzing sound in real time from a sound card or other sound input
board, make sure at least two or three channels are input.
For any localization method, you will probably want to see all available channels on the screen.
(Ishmael allows you to have input channels that it uses for localization but does not display, but
usually it’s better to see all the channels Ishmael is using.) On Ishmael’s main menu, choose View→All
channels.

18.2 Localization methods
Phone pair bearing calculation. A pair of phones determines a hyperbola on which the sound source

lies. When the phones are close together, this hyperbola is very nearly a pair of bearing angles, one on
the left side and one on the right side of the line joining the two phones. When you localize a sound
using this method, bearing angles are plotted on a chart that shows only one of the two bearing
angles, the one between 0°nd 180°. Choose which two phones you wish to use for the bearing
calculation.
Beamforming bearing calculation. This is a method of calculating bearings that relies on a frequency
beamforming algorithm developed by Aaron Thode. It works well with many hydrophones, though
you can use it with as few as two. It’s useful when the sound source is relatively far from the
hydrophone array—say, several times the separation of the most distant phones. Currently, this method
assumes that the phones lie in a straight line, and that the bearings therefore have leftright ambiguity,
similar to phone-pair bearings. There are two different variants of the beamforming bearing calculation,
one that works well for pulses, clicks, and other impulsive sounds, and one that works well for
whistles, moans, and other tonal sounds. Choose the appropriate method for the type of call you’ll be
trying to locate. For tonal sounds, also specify the instantaneous bandwidth of the frequency
contour— that is, specify how tall the contour is in a spectrogram, in Hertz. Results are plotted as for
the phone pair bearing method above.
Hyperbolic X-Y position calculation. These locations are X-Y positions calculated by using differences
in the times that sounds arrive at multiple phones. Conceptually, the time difference for each pair of
phones determines a hyperbola on which the calling animal lies. The intersection of these hyperbolae
determines the animal’s X-Y position. This localization method is useful when the sound source is
relatively close to the phone array—say, closer than several times the separation of the most distant
phones. Positions are plotted on a map; you determine how big the map is using the four values
specified in this dialog box. Choose values large enough to encompass both your phone array and
some space around it.

18.3 Localizing sounds—most methods
Run Ishmael until you see an animal sound you wish to localize. Sounds that span a wide range of
frequencies tend to work best for localization, as they resolve ambiguities better than narrow -band
sounds. If you wish, pause the processing by pressing the space bar or clicking the Pause button (the
one with the two black bars), or halt the processing by clicking Stop button (the one with the red
square).
Select the sound to locate with the mouse by drag-selecting a box around the sound. If you do this
drag-selection without first halting the spectrogram, Ishmael will automatically pause the
spectrogram.

The more tightly you can draw this box around the sound, the less noise is included in the localization
calculation, and the more accurate the location will be. However, you should be sure that the box you
draw encompasses your animal sound in all of the channels; since the sound on some channels may
be slightly delayed relative to others, you may need to draw the box a bit longer on the left or right.
Once you’ve drawn the box, choose from the Localize menu: Beamforming bearing, Phone pair
bearing, or Hyperbolic loc.

18.4 Localizing sounds—beamforming bearings with tonal calls
Instead of drawing a box around the call you wish to localize, you must highlight the frequency
contour by tracing over it. Hold down the Control key and left-click with the mouse at the start of the
contour. Move a bit farther along the contour and do another Ctrl-Left Click. You’ll see a straight line
joining your clicks. Move a bit farther and do another, and the line will grow longer. Keep going until
you reach the end of the contour, then choose Localize → Beamforming bearing from the menu.

18.5 Viewing and saving localization results—all methods
Localization methods that produce bearings—both phone pair and beamforming methods—display
their results as an angle between 0° and 180°. Each bearing shows up as a blue dot on the display, and
the angle of the most recent bearing is also shown in the title bar of the display window. Bearings are
spread out in time in this window, so you can see how the bearings change over time. To expand or
compress the time scale in this display, click the yellow-and-black buttons at the top of the window.

You can send this localization information to another program, such as:
 WhalTrak (Jay Barlow)
 WhaleTrack II (Glenn Gailey)
 WILD (Whale Identification, Logging, and Display – Chris Kyburg)
 You can also save it to a text file……
This will send the current bearing to the serial port as a text string, and the bearing will turn red on
Ishmael’s bearing display. The serial port is configured to use 9600 baud, no parity, one stop bit.
The localization method that produces an X-Y position—the hyperbolic method—
plots its
results on an X-Y diagram, called the map. Hydrophone positions are shown in red on the map, and
the calculated positions are shown in white.

Sometimes the localization algorithm fails to come up with a valid bearing or position. In this case, the
window’s title bar will tell you this; no new bearing or position is plotted.

Note: For any of the localization methods, you can clear the display by choosing
Localize→Clear map from Ishmael’s menu.

18.6 “Instant” localizations
Ishmael has a feature for doing localizations quickly, called Insta-Loc. It’s most useful when analyzing a
real-time signal for calls that don’t vary in duration or frequency band very much.
Here is how it works: You set parameters that specify the duration and frequency band of a call. When
you click in the spectrogram while holding down Shift and Control (Shift+Ctrl+LeftClick), Ishmael
automatically pauses the scrolling and makes a selection around the point where you clicked. Then it
calculates a localization, displays the result (as a bearing or X-Y position, whichever is appropriate),
and un-pauses the scrolling. So with a single mouse click, you get a localization.

19. Beamforming
Beamforming is a way of combining sounds from two or more microphones or hydrophones that
allows you to preferentially hear sounds coming from certain directions. The method used in Ishmael
is a delay-and-sum beamformer, in which sounds from each phone are delayed relative to sounds
from the other phones, and the delayed signals are added. The amount of
delay determines the beam angle—the angle to which Ishmael preferentially “listens.” When an
animal call arrives from this angle, the sound signals from the multiple phones are added
constructively. The resulting sum is stronger, and the call shows up in Ishmael relatively well. When a
sound arrives from another angle, the delayed signals from the various phones add destructively —
with positive and negative parts of the sound waves cancel ing out to some degree—and the sum is
not as loud as an equivalent sound arriving from the beam angle.

The amount of gain you get from beamforming depends on several factors, most importantly on the
number of phones. You get some improvement with only a handful of phones, but it really takes more
than five or six phones to get much gain, and eight is recommended. Many commercial applications of
beamforming use 20, 50, or more phones. Another important factor is coherence. Coherence is a
complex topic, but its impact is that beamforming performance can be degraded significantly if your
phones are too far apart. As a very rough rule, keep microphones (in air) within a few meters to tens
of meters, and hydrophones (in water) within tens of meters to perhaps 2–300 meters. More variable
or turbulent environments require closer placement of phones, and more homogeneous
environments permit wider spacing. Beamforming performance also depends on the frequency of the
signal: higher frequencies result in narrower beams, but they are subject to sidelobes, angles other
than the intended one that have strong gain. Lower frequencies, conversely, have broad beams and
fewer sidelobes. The overall response of a beamformer is usually expressed as a beam pattern, a
circular plot showing the amount of gain for each angle from which sound can arrive.
To use beamforming in Ishmael, choose Compute→Beamforming from the menu. Specify the beam
angles you wish to use, and check the appropriate choice in the x-axis/y-axis box. It is recommended
to check the Enable weighting box. Weighting here is comparable to windowing in computing a
spectrogram, and produces a beam pattern with fewer sidelobes. Ishmael uses Hamming weighting.
If you have installed Matlab on your computer, you can view the beam pattern you will get. Click on
the Plotting tab and follow the instructions to plot a beam pattern, which shows the beam response
in decibels as a function of angle. Note that the beam pattern is dependent on some factors that do
not appear on this tab: The sampling rate of the input signal, the positions of your phones (which are
set via Localize→Loc options), the Enable weighting check box, and the x-axis/y-axis choice all affect
the beam pattern. (Note: In Matlab version 5 and earlier, the option of making polar plots with zero
degrees on the y-axis is not available, so beam patterns are always shown with zero degrees on the xaxis. Regardless of this, beams in Ishmael really do have zero degrees on the y -axis, if that is what you
specify.)

20. Actions
An action is something you specify that Ishmael performs when you tell it to. You tell I shmael to
perform an action by choosing it from the Actions menu, or by typing the action’s hot key. The things
Ishmael can do when performing an action include writing to the log file, saving the current selection
as a sound file, and localizing the current selection. If your action includes several of these things,
then Ishmael will do them all when you ask it to perform the action.
To create an action, choose Actions→Edit actions from the menu, then click New. Give your action a
name and, if you like, a hot key. The action will be performed when you type the hot key. Beware that
hot keys are not checked to see if they are already in use elsewhere in Ishmael. Actions can include
the following steps:
 Continue running (unpause). Often you want to execute an action while Ishmael is paused; this
action makes Ishmael unpause itself and start running again.
 Save the selection as a sound file. If you have selected some sound in the main Ishmael
window, this step will automatically save the selection in the directory you specify. The file
name of the saved sound is specified in the File→Saved file names menu item.
 Go to next file in a batch run. If you are processing a large set of files as a batch, this
terminates processing of the current file and goes on to the next one in the list.
 Execute the current Matlab command. This is the same as choosing Compute→Do Matlab

command from the menu. If there is a selection, it is sent to Matlab as well.
 Calculate location of the selection. This executes the phone-pair localization method. (The
other localization methods should soon be available).
 Logging (on the Logging tab). Various types of information are automatically written to the log
file.
The “Call detected” action is special. This action is performed automati cally whenever a detection
event is triggered (see the “Automatic detection” section above). When this action is performed
automatically this way, the current selection will be the detected call; it can be saved to a file or
logged, as you specify. This action is otherwise like any other action: you can give it a hot key, or
perform it by choosing it from the menu.
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22. Appendix 1: ROCCA Variables
Table 1. ROCCA: Variables measured from whistles
Variable
Begsweep
Begup
Begdwn
Endsweep
Endup
Enddwn
Beg
End
Min
Dur
Range
Max
mean freq
median freq
std freq
Spread
quart freq
half freq
Threequart
Centerfreq
rel bw
Maxmin
Begend
Cofm

tot step
tot inflect
max delta
min delta
maxmin
delta
mean delta
std delta
median
delta
mean slope
mean pos
slope

Explanation
slope of the beginning sweep (1 = positive, -1 = negative, 0 = zero)
binary variable: 1 = beginning slope is positive, 0 = beginning slope is negative
binary variable: 1 = beginning slope is negative, 0 = beginning slope is positive
slope of the end sweep (1 = positive, -1 = negative, = 0 zero)
binary variable: 1 = ending slope is positive, 0 = ending slope is negative
binary variable: 1 = ending slope is negative, 0 = ending slope is positive
beginning frequency (Hertz [Hz])
ending frequency (Hz)
minimum frequency (Hz)
duration (seconds)
maximum frequency - minimum frequency (Hz)
maximum frequency (Hz)
mean frequency (Hz)
median frequency (Hz)
standard deviation of the frequency (Hz)
difference between the 75th and the 25th percentiles of the frequency
frequency at one-quarter of the duration (Hz)
frequency at one-half of the duration (Hz)
frequency at three-quarters of the duration (Hz)
(minimum frequency + (maximum frequency-minimum frequency))/2
relative bandwidth: (maximum frequency - minimum frequency)/center frequency
maximum frequency/minimum frequency
beginning frequency/end frequency
coefficient of frequency modulation (COFM): take 20 frequency measurements
equally spaced in time, then subtract each frequency value from the one before it.
COFM is the sum of the absolute values of these differences, all divided by 10,000
number of steps (10 percent or greater increase or decrease in frequency over two
contour points)
number of inflection points (changes from positive to negative or negative to positive
slope)
maximum time between inflection points
minimum time between inflection points
maximum delta/minimum delta
mean time between inflection points
standard deviation of the time between inflection points
median of the time between inflection points
overall mean slope (Hz/s)
mean positive slope (Hz/s)

Variable
mean neg
slope
mean abs
slope
Posneg
perc up
perc dwn
perc flt
up dwn
dwn up
up flt
dwn flt
flt dwn
flt up
step up
step dwn
step.dur
inflect.dur

Explanation
mean negative slope (Hz/s)
mean absolute value of the slope (Hz/s)
mean positive slope/mean negative slope
percent of the whistle that has a positive slope
percent of the whistle that has a negative slope
percent of the whistle that has zero slope
number of inflection points that go from positive slope to negative slope
number of inflection points that go from negative slope to positive slope
number of times the slope changes from positive to zero
number of times the slope changes from negative to zero
number of times the slope changes from zero to negative
number of times the slope changes from zero to positive
number of steps that have increasing frequency
number of steps that have decreasing frequency
number of steps/duration
number of inflection points/duration

Table 2. ROCCA: Variables measured from clicks
Click variable

Duration

Freqpeak
BW3DB
BW3DBLow
BW3DBHigh
BW10DB
BW10DBLow
BW10DBHigh
RMSSignal
RMSNoise
SNR (Signal-to-noise ratio)
NCrossings
Sweeprate

Description
Click length [s]. Calculated by identifying the
peak amplitude of the click and searching in both
directions until the amplitude has dropped by 12
dB to find the beginning and end times of the
click
Peak frequency [Hz]
-3dB bandwidth [Hz]
-3dB bandwidth lower limit [Hz]
-3dB bandwidth upper limit [Hz]
-10dB bandwidth [Hz]
-10dB bandwidth lower limit [Hz]
-10dB bandwidth upper limit [Hz]
RMS of the click [dB]
RMS of the noise [dB]
RMSSIGNAL- RMSNOISE [dB]
Number of zero crossings
Sweep rate of the zero crossings [kHz/ ms]

Table 3. ROCCA: Ancillary variables measured for each Encounter.
Ancillary Variable
Encounter Duration
Number of Whistles
Number of Clicks
Whistling Duration
Clicking Duration
Minimum Time Between
Whistles
Minimum Time Between
Clicks
Maximum Time Between
Whistles
Maximum Time Between
Clicks
Average Time Between
Whistles
Average Time Between
Clicks
Average Whistles per
Second
Average Clicks per Second
Whistle Density
Click Density
Average Whistle Overlap
Average Click Overlap
Whistle : Click Ratio
Latitude
Longitude

Description
Time from start of first whistle or click to end of last whistle or click
(in seconds)
Total number of whistles
Total number of clicks
Time from beginning of first whistle to end of last whistle (in
seconds)
Time from start of first click to end of last click (in seconds)
Minimum time between the beginning of one whistle and the
beginning of the next whistle (in seconds)
Minimum time between the beginning of one click and the
beginning of the next click (in seconds)
Maximum time between the beginning of one whistle and the
beginning of the next whistle (in seconds)
Maximum time between the beginning of one click and the
beginning of the next click (in seconds)
Average time between the beginning of one whistle and the
beginning of the next whistle (in seconds)
Average time between the beginning of one click and the beginning
of the next click (in seconds)
Number of whistles per second (Number of Whistles / Whistling
Duration)
Number of clicks per second (Number of Clicks / Clicking Duration)
Sum of Individual Whistle Durations / Whistling Duration
Sum of Individual Click Durations / Clicking Duration
Total amount of time whistles overlap other whistles (in seconds)
Total amount of time clicks overlap other clicks (in seconds)
Number of Whistles / Number of Clicks
Latitude (decimal degrees)
Longitude (decimal degrees)

Table 4. ROCCA: Whistle variables used to remove false detections and inaccurate
contour extractions by geographic region. Whistles with values below and/or
above the listed values will not be classified.
Dataset
Northwest Atlantic

Temperate Pacific

Hawaii

Variable
Maximum frequency
Mean absolute slope
Duration
Maximum frequency
Minimum frequency
Duration
Mean absolute slope
Duration
Maximum frequency
Minimum frequency
Mean absolute slope
Frequency range

Remove values
below
10.6 kHz
9.1Hz/s
0.15 s
5 kHz
3 kHz
0.1 s
2 kHz/s
0.1 s
5 kHz
4 kHz
4 kHz/s
0.8 kHz

Remove
values above
27 kHz
82 kHz/s
2.5 s
25 kHz
18 kHz
1.5 s
28 kHz/s
1s
25 kHz
15 kHz
60 kHz/s
14 kHz

Table 5. ROCCA: Click variables used to remove false detections by geographic
region. Clicks with values below and/or above the listed values will not be
classified.
Dataset
Northwest Atlantic
Temperate Pacific
Hawaii

Variable
SNR (dB)
Duration (s)
SNR (dB)
Duration (s)
SNR (dB)
Duration (s)

Prune values
below
N/A
0.005
N/A
0.005
N/A
0.01

Prune values
above
35
0.6
35
0.6
40
0.6

